P.I. Engineering User Forum

Product Support, Technical Questions and Answers, and Examples for P.I. Engineering Products

You are not logged in.

#1 2016-07-31 08:06:54

elgr
Member
Registered: 2016-07-31
Posts: 2

X-Keys Stick SE problem, refering to Error log

Hey hey.

So I got this thing, the Stick SE, from a friend, and it would be amazing if I got it to work.

I am running Windows 10, latest version of Macroworks, on a MSI B85M-E45 motherboard (tried different USB ports from different controllers), and I have the following issues:

1. When connecting the Stick, Macroworks loads up, but I have to assign it a new ID each time I connect it. Then sometimes I get an error saying: "Something went wrong. Please check the error log for details." I have not found an error log. I don't get the error every time though.

2. If the program launches, I can select the Stick and I can make it blink. The red LED's light up, but the switch on the side (which is, as I understand it, a "programming" switch, and it's supposed to open/close the MW gui and allowing it to be programmed) doesn't seem to do anything. I can select keys and create functions though, and the program recognizes the Stick and can

3. When I go to File - Close GUI, I get the "Something went wrong." error. Again, I don't know if there even is an error log. I can choose between "Cancel", "Try again", and "Ignore". "Try again" brings me back to the GUI, but if I made any changes to the keys those are removed.

4. MW is still running in the background at this point (assuming I chose "Cancel" or "Ignore" in step 3), and when I select the icon in the system tray and select the device currently plugged in, I get a Fatal Error saying: "Something went wrong. Please contact the developers with the information in the Error Log." Then the program crashes and the Windows troubleshooting thing starts.

5. Sometimes Step 4 does not happen though, and I can open the GUI again. The changes made to the keys are still present. I just tried to manually change the ID, but then I got the "Fatal Error" again.


I've tried various USB ports without success, and I've fiddled around with users and file access privileges/compatibility/admin modes. It could simply be a faulty Stick I guess, but it would be very nice if that was not the case. It is absolutely unused as far as I know. I have no idea how to proceed now ... except trying older versions of Windows I guess. I actually have a Windows XP machine somewhere...

The required .net bits are installed. I think. I'm pretty sure of it.

Thanks for looking!

Last edited by elgr (2016-07-31 08:08:04)

Offline

#2 2016-08-01 08:43:26

PIE Amber
Technical Software Developer
From: Williamston, MI
Registered: 2016-01-21
Posts: 196
Website

Re: X-Keys Stick SE problem, refering to Error log

These older Sticks require that the programming switch is towards the cord when it attempts to write the Unit ID or it doesn't do it properly. Try closing MacroWorks 3.1 down completely (make sure it exits, and doesn't just live in the background). Then flip the programming switch towards the cord, THEN plug the Stick in. Start up MW3.1. Keep the switch in the programming position until you are completely done programming. Does it behave better now?

As for the errors you're getting, if they persist please provide your error log. It is found at C:\Users\YOUR LOGIN NAME\AppData\Local\PI Engineering\MacroWorks 3\ErrorLog.txt. You need to show hidden files and folders on your computer in order to see this location. You can also open the ErrorLog by Help>About and clicking on the ErrorLog button. It's easiest if you email the file to tech@piengineering.com.


Amber from P.I. Engineering

Offline

#3 2017-03-08 06:10:27

elgr
Member
Registered: 2016-07-31
Posts: 2

Re: X-Keys Stick SE problem, refering to Error log

Hey hey,

Long time no answer from me. I apologize for that. I left some of my projects behind, but now I'm picking them up again, and for some reason, the stick now works flawlessly. I have reinstalled the OS (Windows 10 Pro) a few times since the last time, maybe something in my system was acting up.

But again, now it just works. It is amazing.

Offline

Board footer

Powered by FluxBB