P.I. Engineering User Forum

Product Support, Technical Questions and Answers, and Examples for P.I. Engineering Products

You are not logged in.

#1 2016-09-19 09:11:58

PIE Amber
Technical Software Developer
From: Williamston, MI
Registered: 2016-01-21
Posts: 196
Website

Trouble with RailDriver with Train Simulator 2018?

Since the recent release of Train Simulator 2017, some users have reported trouble connecting their existing RailDriver install to the new update. If you are having these issues, follow the steps below.

If you are not having these issues, simply kick back and enjoy your new simulator.


Please do the following steps with the RailDriver unplugged.

Out with the old:

First uninstall MacroWorks 3.1 via control panel.

Then follow this path C:\Users\YouUserNameHere\AppData\Local and delete the PI Engineering folder.

If the "AppData" folder is not shown, you will need to "Show Hidden Files and Folders" by following these instructions: http://pcsupport.about.com/od/windows7/ … dows-7.htm

In with the new:

This link http://raildriver.com/support/TrainSimulator.php, has the software (“MW3.1 Installation Package v.1.1.1.79) and all the steps you need to install.

Now, right-click the MW3 icon you see on the desktop and choose “Properties>Compatibility Tab>Check mark in the “Run as admin” box>Reboot the computer.

Once the computer is rebooted plug in the RD and launch MW3.1, you should be prompted to re-calibrate the unit.

At this point, if you are using Windows 8/8.1/10, please follow the instructions here: http://raildriver.com/support/TrainSimu … p#windows8, to make sure the msvcr file is included in your installation. While the instructions say "8" they work for all systems after that.


Amber from P.I. Engineering

Offline

Board footer

Powered by FluxBB