P.I. Engineering User Forum

Product Support, Technical Questions and Answers, and Examples for P.I. Engineering Products

You are not logged in.

#1 2016-11-11 18:57:02

jy
Member
Registered: 2016-11-11
Posts: 1

problem: multiple keys firing

i don't know if this is a software or hardware issue (i have an xkeys xk12), but sometimes when i press a key, it triggers a press from all the keys in the same bank (not good)

some keys tend to trigger this behavior (although not on every key press). some keys (and the jog/shuttle dial) never seem to trigger this behavior.

here's what my setup (with controllermate on osx 10.11) looks like:
controllermate-setup.png

so, like, half the time when i'm pressing button #8, buttons #5, #6, #7, and #8 will register as "on" (like they light up and say "on" and everything)

i also posted on the controllermate forum to see if anyone there has any ideas.

does this sound more like a hardware or software problem? should i exchange my controller for a new one?

Offline

#2 2016-11-14 09:31:06

PIE Amber
Technical Software Developer
From: Williamston, MI
Registered: 2016-01-21
Posts: 196
Website

Re: problem: multiple keys firing

It could be a software issue, but I don't see any issues in your programming above. For that reason, I suspect it may be a hardware issue. Are you able to duplicate it with the ControllerMate GUI open? By which I mean can you press a button and eventually see all the button blocks on your programming page turn to "ON"? If so that would confirm a hardware issue.

I got your email about exchanging. It seems likely that's the best way to go. We will respond to you there as well with details.


Amber from P.I. Engineering

Offline

Board footer

Powered by FluxBB