P.I. Engineering User Forum

Product Support, Technical Questions and Answers, and Examples for P.I. Engineering Products

You are not logged in.

#1 2017-05-24 18:29:17

ndiaz
Member
Registered: 2017-05-24
Posts: 2

MacroWorks 3.1 very slow in Software Mode

I find that MacroWorks 3.1 is excessively slow when in Software Mode. I'm using it in Windows 10 and it gets to the point where I sometimes give up programming new macros for my X-keys because it just takes too long. I've tried repairing and reinstalling the software but it hasn't helped. I would appreciate any suggestions, as I would love to be able to quickly program shortcuts as I need them.

Offline

#2 2017-05-31 08:59:20

PIE Liam
Technical Support Specialist
From: Williamston, MI
Registered: 2016-01-21
Posts: 50
Website

Re: MacroWorks 3.1 very slow in Software Mode

Try setting it to run as administrator. Right click the MW3.1 icon on your desktop select "Properties>Compatibility tab>Check mark in the "Run this program as an administrator" box>Apply and reboot the computer to retest and always make sure you are running the latest version of the software found here http://xkeys.com/PISupport/SoftwareMacroWorks.php , I use it with Win10 and I did notice it worked a bit faster with these elevated permissions added.

Offline

#3 2017-06-01 20:02:22

ndiaz
Member
Registered: 2017-05-24
Posts: 2

Re: MacroWorks 3.1 very slow in Software Mode

Thank you. I've now set it up to run it as an administrator. The reboot helps tremendously, with the program responding quickly after the computer has been restarted, but it seems that after the computer has been on for a while and several programs have been opened, MacroWorks once again starts to become less responsive.

Offline

#4 2017-06-29 18:44:39

JustLowe42
Member
Registered: 2017-06-29
Posts: 1

Re: MacroWorks 3.1 very slow in Software Mode

I am having the same issue. You are not alone. Of course, I have no answer either.

Offline

#5 2017-10-06 19:43:31

HungTranMD
Member
Registered: 2016-03-01
Posts: 2

Re: MacroWorks 3.1 very slow in Software Mode

I am having the same issue; using Software mode in Windows 10; version MW3.1(1.1.1.89)Installer_rev1.  I found this article.  http://www.titam.ca/2017/07/pi-engineer … -keys.html.  The author said you have to elevated the graphical interface MacroWorks3g.exe in the C:\Program Files (x86)\PI Engineering\MacroWorks 3.1 folder.  I hope that PIE fixes the problem soon; it is aggravating.

Offline

#6 2017-10-18 15:24:29

Crunch
Member
Registered: 2017-10-11
Posts: 2

Re: MacroWorks 3.1 very slow in Software Mode

Try setting the software (both parts) to not only run as admin but also to run in "Compatibility mode" for Windows 7, this helped for me.

Offline

#7 2017-10-21 05:36:06

euclid
Member
Registered: 2017-09-23
Posts: 2

Re: MacroWorks 3.1 very slow in Software Mode

same issue here. MacroWorks 3.0 is much faster.

Offline

#8 2017-10-23 20:56:52

ckmaui
Member
Registered: 2017-10-23
Posts: 4

Re: MacroWorks 3.1 very slow in Software Mode

on 3.1 brand new to PC (win 10) this was a great tip

for me I had to do both the win 7 and the admin and just launch the 3g.exe as HuangTran mentioned in that article post above

otherwise was unusable

Offline

#9 2017-11-16 13:33:24

VM Sakai
Member
Registered: 2017-11-16
Posts: 1

Re: MacroWorks 3.1 very slow in Software Mode

Please add me to the list of users having the same problem.

Even with compatibility mode changes, the program is slow and unusable. Its likely that there is a problem with the program's screen redraw. Here's a screenshot of the Task Manager details. The component of Macroworks called MacroWorks3g.exe loops from Running to Not Responding. https://twitter.com/fugubot/status/931216461967716352

Also let us upload screenshots to this forum to help support.

Thanks.

Last edited by VM Sakai (2017-11-16 13:46:13)

Offline

Board footer

Powered by FluxBB