RailDriver Desktop Train Cab Controller

RailDriver Desktop Train Cab Controller

Decorative Hitch Cover

Decorative Hitch Cover

RailDriver & Train Simulator 2020

Drive your train with realistic throttle, brake, reverser, and switch controls, plus 34 programmable buttons. RailDriver® Desktop Train Cab Controller makes you feel like you're driving a train, not a computer now bundled with Dovetail's Train Simulator 2020 game.

$239.94
In stock
SKU
RD-1384-DCTS-R

RD Close-Up

Features

The RailDriver® Desktop Train Cab Controller includes prototypical levers and controls for the ultimate interface to computer-based railroading. An internal bass speaker supplements your existing sound system and adds realistic vibration to the controls.



Main Features

  • Capture the perfect scenes in the all new Railfan mode
  • Create your own routes with powerful in-game editing tools

System Requirements

Minimum System Requirements for 32-Bit

  • OS: 32-bit Windows 7 Service Pack 1, 8.1 or 10 Required (Other OS versions and types are not supported)
  • Processor: Intel Core-i3 4330 3.50 GHz Dual Core or AMD A8 6600K 3.90 GHz Quad Core or Better
  • Memory: 4 GB RAM
  • Graphics: NVIDIA GeForce GTX 750 Ti or AMD Radeon R9 Graphics with 1 GB Dedicated VRAM or Better
  • DirectX®: 9.0c
  • Network: Broadband Connection (May incur additional costs for use)
  • Storage: 40 GB or more available space (Additional Add-Ons will require more)
  • Sound Card: DirectX Compatible Audio Device
  • User Manual
  • Additional Notes: Requires mouse and keyboard or Xbox Controller Laptop, Notebook, Mobile or Low Power versions of the above specifications (including Intel or Integrated Graphics) may work but are not supported. Updates to Chipset, Graphics and Audio Device Drivers may be required. For information relating to recommended specifications for Train Simulator 64-bit, please refer to the Train Simulator 2019 User Guide.

Recommended System Requirements for 32-Bit

  • OS: 32- or 64-bit Windows 7 Service Pack 1, 8.1 or 10 Required (Other OS versions and types are not supported)
  • Processor: Intel Core-i5 4690 3.50 GHz Quad Core or AMD Ryzen 7 1700 3.80 GHz Quad Core or Better
  • Memory: 4 GB RAM (maximum possible under 32-bit Windows)/16 GB or Better (For 64-bit Windows)
  • Graphics: NVIDIA GeForce GTX 970 or AMD Radeon RX 480 with 4 GB Dedicated VRAM or Better
  • DirectX®: 9.0c
  • Network: Broadband Connection (May incur additional costs for use)
  • Storage: High Performance SSD Recommended with 40 GB or more available space (Additional Add-Ons will require more)
  • Sound Card: DirectX Compatible Audio Device
  • Additional Notes: Requires mouse and keyboard or Xbox Controller
  • Laptop, Notebook, Mobile or Low Power versions of the above specifications (including Intel or Integrated Graphics) may work but are not supported. Updates to Chipset, Graphics and Audio Device Drivers may be required. For information relating to recommended specifications for Train Simulator 64-bit, please refer to the Train Simulator 2019 User Guide.

Help and install instructions can be found here.

RD

RailDriver Compatibility

RailDriver®
Compatibility
XP (32)
Vista (32)
Vista (64)
Windows 7 (32/64)
Windows 8/8.1 (32/64)
Windows 10 (32/64)
Train Simulator 2019
Yes
Yes
Yes
Yes
Trainz RailRoad Simulator 2019
Yes
Yes
Yes
Yes
Yes
Yes
Trainz A New Era
Yes
Yes
Yes
Yes
Yes
Yes
Trainz 2009 / 2010 / 12
Yes
Yes
Yes
Yes
Yes
Yes
Run8*
Yes
Yes
Yes
Yes
Yes
Yes
My First Trainz Set
Yes
Yes
Yes
Yes
Yes
Yes
Trainz Railwayz / 2006
Yes
Yes
Yes
Yes
Yes
Yes
Trainz Classics
Yes
Yes
Yes
Yes
Yes
Yes
Trainz 2004
Yes
Yes
Yes
Yes
Yes
Yes
World of Subways 2 & 3*
Yes
Yes
Yes
Yes
Yes
Yes
TrainMaster 4.3
Yes
--
--
Yes
Yes
Yes
MSTS
Yes
**
**
**
**
**
Open Rails*
Yes
Yes
Yes
Yes
Yes
Yes

*World of Subways 2 and 3, Open Rails, and Run8 do not require additional software from us. They provide native support.

*RailDriver Instructions for Open Rails